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CS-592: Introduction Service Networks 
Spring 2015 

 

 Assisting Lecture: Java Restful Web Services in 
the Google App Engine 

Myron Papadakis (myrpap@gmail.com) 



Creating and Deploying Web applications in 
Google App Engine 

Example 1: Hello World Example using JAX-RS 
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Download Jersey 

• Download the Jersey distribution as zip file from the Jersey 
download site.  

– jaxrs-ri-2.16 or jaxrs-ri-2.17.zip 

– It is a collection of jars.. 

 

• The zip contains the Jersey implementation JAR and its core 
dependencies.  

– It does not provide dependencies for third party JARs 
beyond those for JSON support and JavaDoc.  

– This means that in many cases we have to add some jars 
from external parties….(i.e. jaxb and gson) 
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Eclipse > Create new Dynamic Web 
Project 
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Eclipse > Create new Dynamic Web 
Project 
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Jersey Jar Copy 

• Copy all JARs from your Jersey download into the WEB-INF/lib 
folder.  

20/4/2015 6 CS-592 Spring 2015 - Myron Papadakis 
Transformation Systems Laboratory 



Create New Class (Resource) 
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Create New Class (Resource) 

package cs592; 

 

import javax.ws.rs.GET; 

import javax.ws.rs.Path; 

import javax.ws.rs.Produces; 

import javax.ws.rs.core.Response; 

import javax.ws.rs.PathParam; 

import javax.ws.rs.QueryParam; 

import javax.ws.rs.FormParam; 

import javax.ws.rs.POST; 

@Path("/hello") 

public class HelloResource { 
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Create New Class (Resource) 

 @GET 

 @Path("/query") 

 @Produces("text/html") 

 public String getGreetingQueryParam(@QueryParam("name") 
String name) { 

        return "<html><body><h1>Hello " + name + 
"!</h1></body></html>"; 

 } 

 

 @GET 

 @Path("{name}") 

 @Produces("text/html") 

 public String getGreetingParam(@PathParam("name") String 
name) { 

       return "<html><body><h1>Hello " + name + 
"!</h1></body></html>"; 

 } 
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Create New Class (Resource) 

 /* 

     * Html File should be located to the WebContent 
folder 

     * Invoke: http://localhost:8080/HelloRest/form.html 

     */ 

    @POST 

    @Path("/form") 

    public Response sayHiToUser( 

            @FormParam("fname") String fname, 

            @FormParam("lname") String lname) { 

 

        String output = "<html><body><h1>Hello " + fname + 
" "+lname+"!</h1></body></html>"; 

 

       return Response.status(200).entity(output).build(); 

 

    } 

 

} 

 

20/4/2015 10 CS-592 Spring 2015 - Myron Papadakis 
Transformation Systems Laboratory 



Create New HTML File  
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Define Jersey Servlet dispatcher 
> web.xml 

• Default generated web.xml should look like the following 

• We have to modify it to deploy it to Tomcat 
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Define Jersey Servlet dispatcher 
> web.xml 

• You need to register Jersey as the servlet dispatcher for REST requests.  
• The complete path to a resource is based on the base URL and the @PATh 

annotation in your class.  
 

• http://your_domain:port/display-name/url-pattern/path_from_rest_class  
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Running in Tomcat 
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Running in Tomcat 
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Running in Tomcat 

• Don’t worry if you see the following page 

• Remember 

• http://your_domain:port/display-name/url-
pattern/path_from_rest_class  
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Running in Tomcat > PathParam 
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Running in Tomcat > QueryParam 
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Running in Tomcat > FormParam 
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Google App Engine 
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Note 

• Unfortunately for Netbeans the google app engine plugin 
does not work smoothly. 

 

• There are a lot of conflicts with libraries and it is very 
frustrating 

 

• https://code.google.com/p/nb-gaelyk-plugin/downloads/list 
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Google Plugin for Eclipse 

• https://developers.google.com/eclipse/docs/download 

 

• Complete Instructions are given here (for example for 
Keppler) 

– https://developers.google.com/eclipse/docs/install-
eclipse-4.3 

 

• Install the plugin and Restart the Ide 

 

• https://developers.google.com/eclipse/docs/signin 
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Google Plugin for Eclipse 
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Google Plugin for Eclipse 
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Google Plugin for Eclipse 
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Google Plugin for Eclipse 
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Google Plugin for Eclipse 
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Google App Engine Java Support 
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Java: 
• App Engine runs JAVA apps on a JAVA 7 virtual machine (currently     

   supports JAVA 6 as well). 
• Uses JAVA Servlet standard for web applications: 

•WAR (Web Applications ARchive) directory structure. 
• Servlet classes 

• Java Server Pages (JSP) 
• Static and data files 

• Deployment descriptor (web.xml) 
• Other configuration files 

• Getting started : 
https://developers.google.com/appengine/docs/java/gettingstarted/ 

 

https://developers.google.com/appengine/docs/java/gettingstarted/


Checking Installation 
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Eclipse Steps 

• Create a new application with a certain id in the google app engine. 

 

• Create a new Google Web Application Project 

 

• Configure build path 

 

• Copy to lib all the jersey jars… 

 

• Change web.xml 

 

• Check and fill in the application id in the appengine-web.xml 

 

• There is no need to have Apache Tomcat or Glassfish installed! 
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Google App Engine 

Hello Example 

20/4/2015 31 CS-592 Spring 2015 - Myron Papadakis 
Transformation Systems Laboratory 



Google app engine > create app 
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Google app engine > create app 
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Google app engine > create app 
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Google App Engine Project 
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Google App Engine Project 

Untick it 
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Google App Engine Project > 
Structure 
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Creating the project 

1. You'll add your own application Java classes to 
src/main/java/... 

 

2. You'll configure your application using the file 
src/main/webapp/WEB-INF/appengine-web.xml 

 

3. You'll configure your application deployment using the file 
src/main/webapp/WEB-INF/web.xml 
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Creating the project > Step1 

• So first we will create the resources (actually copy them from 
the previous project) 
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Creating the project > Step1 
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Creating the project > Step1 

• I will also copy the html for the form but I will have to change 
the path of the action 
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Configuration 

• Configuring the REST support in the application 

– To be able to create and run REST services in your application you 
need to: 
Add the JAX-RS, JAXB Jars in your project and application 

– Configure the web application (web.xml) to handle REST requests 

• Add JAX-RS, JAXB to your project 
Right click on the project and select menu entry Build Path > Configure 
Build Path... 

• Click on the Add External JARs button 

• Select all the JARs located in $JERSEY_HOME/lib  and $JAXB_HOME/lib 
folders. You can for better visibility and reuse create a user library with all 
these JARs 

• You also need to copy the JARs in the web-inf/lib directory of your 
application, this step is mandatory to be sure that the JARs are included in 
the application when deployed to App Engine. 
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Create a user library for Jersey 

• Window > Preferences > Java > Build Path > User Libraries > 
New > .. Add External Jars > add the jersey jars 
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Library Loaded to build path 
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Configuring the build path 

• You must also copy the jars to the lib folder 
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Configuration > Default generated 
xml file 
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Configuration > Modified web.xml 

• The configuration parameter jersey.config.server.provider.packages is used by 
Jersey to list the packages where REST services implementation are located.  

• You can put as many package as you need to, you just need to separate the 
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Deploying the application to 

Google App Engine 
 

• Before deploying the application you need  

– to register a new application in Google App Engine using the 
Administration Console (see next slide).  

– In my example I have used “cs592hello" as Application ID.  
 

• You can easily now deploy the application to Google App Engine by 
clicking on the  "Deploy App Engine Project" button  available in the 
Eclipse toolbar.  
 

• To be able to deploy your application to Google App Engine, you need to 
check that your application can be registered, the application ID is stored 
in the WEB-INF/lib/appengine-web.xml.  
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Deploying the application to Google App 
Engine > appengine.web-xml 

• Has extra configuration file appengine-web.xml which specifies: 

– Name of application: 

• <application name>.appspot.com 

– Version of application 

– Logging 

– Enabling HTTP Sessions 

– Enabling SSL 

– System properties and environment variables 

– Differentiating between static and resource files 

• By default all files under /war directory are both resource and 
static files except .JSP and those under /WEB-INF 



Deploying the application to Google App 
Engine > appengine.web-xml 

 

23/3/2015 CS-592 Spring 2015 - Myron Papadakis 
Transformation Systems Laboratory 

52 20/4/2015 52 CS-592 Spring 2015 - Myron Papadakis 
Transformation Systems Laboratory 



 
Deploying the application to 

Google App Engine 
 

• Right click on the project 
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Deploying the application to Google App 
Engine > Credentials 

• The App Engine deploy button prompts you for multiple informations:  

– username (your Google account) and password.  
 

• When the deployment is complete you can access your application using 
the following URL: 
http://[your-application-id].appspot.com/url-
pattern/resourcepath/methodpath 

 

• http://cs592hello.appspot.com/hellorestgae/hello/Myron 
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Deploying and uploading… 
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GAE success  
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GAE success  
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Book Example 
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Book Restful Web Service 

• Remember the Book Example? 

 

• See Assisting Lecture 7b to recall… 

– We have developed it in Netbeans… 

– Now we will develop it in Eclipse 

 

• We want to deploy this example to the Google App 

Engine 

 

• No need to modify existing Java code (packages etc) 
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Book Restful Web Service 

• For starters develop a Restful Service that 

– Returns all books 

– Returns a book with a given id 

– Adds a book 

• Obviously we will need a structure for the books (list, map or whatever) 

• Firstly, the Restful Web Service must create a dummy book 

• Each book has 

– Id 

– Name 

– Author 

– Isbn 

– Price 
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Untick it 



Creating the project 
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BookResource Class 

• z 
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BookResource Class 
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Configuration > Default generated 
xml file 
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Configuration > Modified web.xml 

• This servlet that will answer all 
request the /bookgae/* URL 
and redirect them to classes 
representing RESTfull services  

• The configuration parameter 
com.sun.jersey.config.property.
packages is used by Jersey to 
list the packages where REST 
services implementation are 
located.  

• You can put as many package 
as you need to, you just need 
to separate the package names 
by a ; 

• You do not need the welcome 
file too (since you will not use a 
servlet) 
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Optional (If you want to use 
servlets) 

 

20/4/2015 69 CS-592 Spring 2015 - Myron Papadakis 
Transformation Systems Laboratory 



 
Deploying the application to 

Google App Engine 
 

• Before deploying the application you need  

– to register a new application in Google App Engine using the 
Administration Console (see next slide).  

– In my example I have used “cs592book" as Application ID.  
 

• You can easily now deploy the application to Google App Engine by 
clicking on the  "Deploy App Engine Project" button  available in the 
Eclipse toolbar.  
 

• To be able to deploy your application to Google App Engine, you need to 
check that your application can be registered, the application ID is stored 
in the WEB-INF/lib/appengine-web.xml.  
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Deploying the application to Google App 
Engine > appengine.web-xml 
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Deploying the application to 

Google App Engine 
 

• Right click on the project 
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Deploying the application to 

Google App Engine 
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Deploying the application to Google 

App Engine > Uploading 

20/4/2015 CS-592 Spring 2015 - Myron Papadakis 
Transformation Systems Laboratory 

74 



Google App Engine > Create 
Application 
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25 Applications for free  



Deploying the application to Google App 
Engine > Credentials 

• The App Engine deploy button prompts you for multiple informations:  

– username (your Google account) and password.  
 

• When the deployment is complete you can access your application using 
the following URL: 
http://[your-application-id].appspot.com/url-
pattern/resourcepath/methodpath 

 

• http://cs592book.appspot.com/bookgae/bookresource/books 
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Initial page as set from the index.html 
(which is the welcome file) 
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Testing on HttpRequester Mozilla 
Add on 

 

 
• http://cs592book.appspot.com/bookgae/bookresource/books 
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Post Example 

• Post a Book (in XML format) 
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Get Example > Book is added 

• The second book has been added successfully 
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Delete a book 

• Delete the first book 

 

 

 

 

• Get back all books (to check if deleted) 
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Get books (after deletion) 
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Google Gson 
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GSON 

• Gson is a Java library that can be used  
– to convert Java Objects into their JSON representation.  
– It can also be used to convert a JSON string to an 

equivalent Java object.  
 
https://code.google.com/p/google-gson/ 
 
http://www.studytrails.com/java/json/java-google-json-
introduction.jsp   
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Gson Example (for Book) 
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Gson Example (for Book) 
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Add Gson Code 

• Right click on project->Property->java build path->Add jars 
and then go to src->jars->gson-2.3.1.jar. 
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BookExample with GSON > get all 
books 
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BookExample with GSON > get all 
books 

• Returned in JSON format 
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BookExample with GSON > get a 
book 
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References 

• http://howtodoinjava.com/2014/06/17/google-gson-tutorial-
convert-java-object-to-from-json/ 
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Τέλος Ενότητας



Χρηματοδότηση
•Το παρόν εκπαιδευτικό υλικό έχει αναπτυχθεί στα πλαίσια του εκπαιδευτικού 
έργου του διδάσκοντα.

•Το έργο «Ανοικτά Ακαδημαϊκά Μαθήματα στο Πανεπιστήμιο Κρήτης» έχει 
χρηματοδοτήσει μόνο τη αναδιαμόρφωση του εκπαιδευτικού υλικού.
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