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Outline

e Apache Ode

e Eclipse BPEL Designer
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Apache Ode

e Apache ODE (Orchestration Director Engine) is an open
source BPEL engine.

e Full support for WS- BPEL 2.0 OASIS standard.
e Hot-deployment of processes.

e Management interface for processes, instances and
messages.
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Apache Ode

e Download latest stable release: ODE 1.3.5 war distribution from
http://ode.apache.org/getting-ode.html

e Installation:
— Unzip package. Copy this file to Tomcat’s webapp.
— Start Tomcat and ODE should be up and running.

i(—) * v Computer » O5(C) » apache-tomcat-7.0.35 » webapps »

s BAXV= @

- E . Mame Date modified
- Favorites
B Desktop | axis2 2/3/2013 1:51 pp
4. Downloads , docs 10/1/2013 10:54 pp
# Dropbox | examples 10/1/2013 10:54 pp
L Google Drive . host-manager 10/1/2013 10:54 pp
| Recent places | manager 10/1/2013 10:54 pp

. ode 27372013 27 pp
= Libraries ROOT 10/1/2013 10:54 pp
1

3 Documents axisd.war T2 2 724 pp
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http://ode.apache.org/getting-ode.html
http://ode.apache.org/getting-ode.html
http://ode.apache.org/getting-ode.html

Testing Apache Ode

http://localhost:8080/ode
Pl Apache Tomeat/7035  x Y [ Apache Tomeat/7.035 X J [ Apache ODE | Home X _

€& - C [Y localhost:8080/0de/

Mo ypnyepn mpoofoon, TomoBeThnot: Toug oehibodelkteg oog 8w ot ypoppn cehdodarTwy, Bugoyuwyn gchiboSakTwy Twpo.,

Apache ODE

Instances Deployment Deployment Browser

Summary of Instances
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Deploying a process to Apache Ode

e http://ode.apache.org/creating-a-process.html

e Each deployment is a directory with a relevant deployment artifacts
— One or more processes (.bpel)
— WSDL and XSD files

— Deployment descriptor (deploy.xml): configuration of services that
processes uses. For each process,

e partnerlinks are bind to concrete WSDL services
e <receive> is correlated to <provide> element
e <invoke> is correlated to <invoke> element
e To deploy, copy the whole directory containing your artifacts in the
— “<tomcat-home>/webapps/ode/WEB-INF/processes”
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Eclipse

\
3

Designer
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Eclipse and BPEL

e |nstalling and Configuring Eclipse with the BPEL Designer

e Forinstalling plug-ins and additional packages go to: Help = Install New
Software

e Inthe text field with label “Work With” enter
http://download.eclipse.org/bpel/site and from the list select “Eclipse
BPEL Designer”

e After installation of new packages, Eclipse IDE must be restarted.

e In order to check installed software, plug-ins and tools, try: “Help”
>“About Eclipse” and click “Installation Details”
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http://download.eclipse.org/bpel/site

Eclipse BPEL Designer

Awvailable Software
Check the itermns that you wish to install.

Work with: | BPEL - http://download.eclipse.org/bpel/site

type filter text

Mame

Wersion

| & []000 Eclipse BPEL Designer

L+ BPEL Commons
Lir BPEL Visual Designer
L Runtime Adapter for Apache ODE 1.3
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Eclipse and BPEL

e To verify the installation has been successful, after the restart, click on
File > New = Other (in order to create a new project)

e Verify that there isa BPEL 2.0 Entry in the Wizard

Select a wizard

Wizards:
type filter text

[+ = General A
[+ = Acceleo Model to Text

a = BPEL 2.0

Y BPEL Deployment Descriptor
%2 BPEL Process File
EL Project
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Eclipse and Apache Ode

e Setup a ODE Server inside Eclipse
— “Window—>Preferences->Server->Server Runtime” and “Add”

MNew Server Runtime Environment

Define a new server runtime environment

MNew Apache Ode 1.x Runtime Runtime

Select the type of runtime environment: Define a new Apache Ode 1.x Runtime runtime

|t],rpe filter text

4 [= Apache You can use |nstalled JRE preferences to create a new JRE
| ¥ Apache Ode1x Runtime| IRE: Default JRE v|
B Apache Tomcat v3.2 —— —
B Apache Tomcat v4.0 ODE's h directory: | Ci/apache-tomcat-7.0.35/webapps/ode
E Apache Tomcat w41
E Apache Tomcat v5.0 Tomcat's directony: | C:/apache-tomcat-7.0.35 N /H Browse...
B ApacheTomcatvs5 Server address: rlﬂcalhust |
B Apache Tomcat v6.0
& Apache Tomcat vi.0 Port: | 8080 |
[» [= Basic v

Apache's BPEL 2.0 execution engine - Runtime

= B8
0 & BT
18/5/2014 > |_1’E Ode v1.x Server at localhost [Stupped]|

[ ﬁ Tomcat v7.0 Server at localhost [Started, 5y
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Eclipse BPEL Project

e File > New = Other - BPEL 2.0 = BPEL Project

Select a wizard

Create a new BPEL project.

Mew BPEL Project
Create a new BPEL 2.0 project.

Wizards:

Project name: | HelloBPELProject

| type filter text

Project location

(& Class

€4 Interface
2% Java Project
¥ )ava Project from Existing Ant Buildfile
12 Plug-in Project
[+ = General
[ = Acceleo Model to Text
[ = foos2 Wizards
4 (= BPELZ.0
([ BPEL Deployment Descriptor

< i;f% BPEL Project 5

Uze default location

Location: | Chworkspace\HelloBPELProject Browse...

runtime \

|Apache Ode 1.x Runtime w )New Runtime..
o

/

Configuration

|Defau|t Configuration for Apache Ode 1.x Runtime V| | Madify...

The default configuration provides a good starting point. Additional facets can later be
installed to add new functionality to the project.
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Eclipse BPEL Project

BPEL Title
EPEL Description

——
Content Fol bpelContent /

@ This kind of project is associated with the BPEL perspective. Do you want to open

this perspective now?

[ 1 Rernember rmy decision

Yes Mo
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BPEL File

e Right click on the folder of your choice (i.e /bpelcontent)
— New ->0Other > New BPEL Process File”

18/5/2014

Select a wizard —
[

Wizards:
type filter text

(& Class M

€¥ Interface
[g Java Project
F Java Project from Existing Ant Buildfile
£ Plug-in Project
[ [ General
[ [ fcceleo Model to Text
[ = fois2 Wizards
4 = BPELZ.D

escriptor
BPEL Process File
=] v
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Create a BPEL Process File
Create a new BPEL file (BPEL 2.0).

BPEL File

Creation Mode: | Create a BPEL process from a template v

Process Mame: | HelloWeorld

Mamespace: | http://helloworld|

[] Abstract Process

Select Files Location

Select location for the BPEL source files.

Enter or select the parent folder:

| HellcBPELProject/bpelContent

it
= HelloBPEL
== HelloBPELProject
= .settings
= bpelContent
== Servers
1= Test

g.';‘f- TravelReservation

File name: | HelloWorld.bpel

Use a Creation Template
Create a BPEL process from a template,

Template: | Synchronous BPEL Process v |

Generates an empty BPEL process. Only receive and reply activities are placed in the process
body. The caller will block until all the steps in the process have completed, A client interface is
generated,

Template Properties

Service Name: | HelloWerldService |

Port Mame: | HelloWerldPort |

Service Address: | http://localhost:8080/HelloWorld |

Binding Protocol: | SOAP v
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BPEL File

[ Project Explorer 2 = O 2 HelloWerld.bpel &2

= q:bl 23 7 | 22 HelloWorld

= TElloEPEL ] i Partner Links
1= HellcBPELProject client
= bpelContent main :
& HelloWaorld.bpel = TR
AP HelloWorldArtifac input

o | receivelnput

=+ Server output

i Test Correlation Set

% TravelReservation FIX_ME-Add_Business_Logic_Here | erTEEimes
= #% Message Exchanges

(72 JSR-109 Web Services
2| replyOutput

@
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BPEL File

18/5/2014

q Design | Source )

1—— HelloWorld BPEL Process [Generated by the Eclipse BPEL Designer] ——[
«!-— Date: 5un Apr 21 15:18:54 EEST 2013 ——>

Z<bpel:process name="HelloForld"

targetlamespace="http:/ hellovorld™

suppressdJoinFailure="yas"

xmlns:tns="http://hellovorld"
xmlns:bpel="http://docs.oasis—open.org/vsbpel/ /2. 0/ process/executable"
>

<!—— TImport the client WSDL —->
<bpel:import location="HelloWRorldidrtifacts.wsdl"™ namespace="http:/ hellovorlid"
importType="http://schemas.xmlsoap.org/wsdl/; "™ />

v - -2
«!—-— PARTHERLINES =
<!'—— List of services participating in this EBPFEL process -
ol—— -

L= <bpel:partnerLinks>

<1—— The 'client' role represents the requester of this service. -->
<bpel:partnerlink name="client"
partnerlLinkTyvpe="tns:HelloWorid"
myRole="HelloWorldProvider"
S

</bpel:partnerlinks>
£

CS-592 Spring 2015 - Myron Papadakis
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Example

We want to design an application that
responses the client the same string that it
send to the service provider.

Therefore, we have to add an activity which < *HelloWorld.bpel 72
assign the received input to the output.

To do this, click on the Assign activity on the 5 _main
Actions folder of the Palette and drag it to

the space between the receivelnput and
replyOutput activities (if it is not already Assign
present)

& | receivelnput

2| replyCutput
IF it is present simply rename the assign @®
activity from “FIX_ME-

Add_Business_Logic_Here” to “Assign”

18/5/2014 CS-592 Spring 2015 - Myron Papadakis

18



Example

e Right click on the Assign activity. Select Show in properties.

e Inthe Properties tab, select Details. Click on the New button to define an
assign operator.

e Assign from input->payload->input to output->payload->result.
An Initializer popup dialog appear. Click Yes to initialize the output
variable and save the process.

Design | Source

T Properties &3 (%! Problems | ¥ Tasks| & Console =5 Progress

Assign
Description Action Category: v | Description:
Details ) .
Choose one of these actions: Asslgn
loin Behavior
Namespaces &1 2| €3 Use this activity t
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Example

18/5/2014

</tns:HelloWorldResponses»

(S-592 Spring 2015 - Myron Papadakis

@ output: HelloWorldResponseMessage
[ paylead : HelloWerldResponse

[e] result: string

M@, Problems} @ Tasks} =] Console} =3 Progrm} 7Y =0
= Assign
Description [Tvalidate
Details From: Variable To: |Valiahle v
doipEchaving @ input: HelloWorldRequestMessage » @ input:HelloWorldRequestMessage
Mamespaces 7] payload : HelleWerldRequest 4 @ output: HelloWorldResponseMessage
Documentation [e] input: string a [17] payload : HelloWorldResponse
@ output: HelloWorldResponseMessage
@ Variable cutput doesn't have initializer. Should it be generated?
vs  ])
M_ﬂ] Problems} @ Tasks} E Console} =3 Progras} =~ =0
= Assign
—— [Jvalidate
Details Fixed Value to Variable From: Fixed Value To: Variable W
Join Behavi Variable to Variable
n tor «tnsiHelloWorldResponse xminsitns="http://helloweorld” xmlns:xsi=" @ input: HelloWorldRequestMessage
Mamespaces <tnsiresult>tnsiresult< /tnsiresult>
Documentation

20



WSDL

e The BPEL process is designed.

e Now we have to define the Service, Binding type and PortType address to run the
HelloWorld service.
e Right click on the HelloWorldArtifacts.wsdl file, select Open With->WSDL Editor.
2 HelloWorld.bpel 22 *HelloWorldArtifacts.wsdl 52 =
45 HelloWorld5Service €9 HelloWorld
= HelloWorldPort 48 process
http://localhost:2020/H... A L+l input payload =[] HelloWorldRequest
<1 output payload [e] HelloWerldResponse
< >
Design | Source
T Properties 3 [£i Problems| ¥ Tasks| &l Console| 5 Progress
E port
General Marme: HelloWorldPort
Decumentation Binding: | Hellok inding
18/5/2 Extensions Addrest http:_."_."'lDca||"IDSt:SDBD_."'FJFDCESSES_.'HEHIMD

21
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Deploy BPEL in Apache Ode

e Tolet the Apache ODE know your declarations and designs.

You have to add a descriptor. Right click on the BPEL _HelloWorld project,
select New->Others->BPEL 2.0->Apache ODE Deployment Descriptor.

Select a wizard

Apache ODE Deployment Descriptor

This wizard creates a new Apache ODE deployment descriptor file

(deploy.xml). Mote that the file name cannot be changed.
Wizards:
type filter text BPEL Project: | /HellcBPELProject/bpelContent Browse...
& Class File name: deploy.xml
€4 Interface

122 Java Project

ﬁﬁ lava Project from Existing &Ant Buildfile
| 4
T’ﬁ.t';: % Plug-in Project

[+ = General
[ E;- AC_CE|ED_MDdE| to Text :Lﬂ’ HE”U‘EPELPFU‘JECI:
[ = fois? Wizards
T EPEL 20 @ i‘j bpelContent Finish Cancel
<\L1 BPEL Deployment Dﬁcri;t;; Jfl' deploy.xml e
52 BPEL Process File 52;.. HE||DWCI-F|d.pr|
1% BPEL Project —
18/5/2014 C5-592 Sprir = HelloWaorld.bpelex 29
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Deploy BPEL in Apache Ode

e Inthe Inbound Interfaces table, select the Partner Link as client, Associate
Port as HelloPort. Click on Related Service then other fields will be
automatically filled. Save the "deploy.xml" file.

2 HelloWorldbpel | 2@ HelloWorldArtifacts.wsdl ¥ deployxml 2
£ Process Helloworld - http:/fhelloworld

- General

This processis | activated v

(] Run this process in memory

+ |nbound Interfaces (Servic

contains interfaces the process provides,

ervice, port and binding you want
to use for each PartnerLink listed

Partner Link  Associated Port  Related Service  Binding Used

client -- none -- -- none -- -- none--

S~ + Inbound Interfaces (Services)

S ——— —

TWﬁaces the process ;:lr-:uﬂ?i’p&s'@@mr port and binding you want
+ Outbound Interfaces (Invokes) to or each PartnerLink listed

The table contains interfaces the process invokes, Specify the service, port ¢ Gartner Link Associated Port  Related Service  Binding Used
use for each PartnerLink listed

|}Mt\He||.:w.:.r|dpart {http://hello...  HelloWorld,
Partner Link  Associated Port  Related Service  Binding Used
? I

Myron Papadakis 23
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Time to run the process

e Now you have finished your designs and it's time to run the process.

e However, the ODE Server on the Eclipse could not recognize your BPEL
process because it is designed after the server's set up.

e Therefore you have to restart your Eclipse (File = Restart)

e After the restart, right click on the Ode v1.x Server at localhost,
select Add and Remove Projects

e Select the BPEL_HelloWorld/HelloWorld in the Available projects box
and click Add. Then, click Finish.

e Start the ODE server. If the deployment was successful, you will
something similar to the following output in the console tab.

15:57:19,709 INFO [DeploymentPoller] Deployment of artifact HelloBPELProject successful: [{http://helloworld}HelloWorld-6)
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Testing the process

e  We will test the "Hello World"
deployment with Web Services
Explorer provided by Eclipse.

e Rightclickon

the HelloWorldArtifacts.wsdl file.

Select Web Services->Test with
Web Services Explorer.

e Select the operation process. Then, <

type "Welcome to BPEL” in the
input textbox.

e If your deployment was success, you
will get the same string in the SOAP

response

-

18/5/2014 CS-592 Spring 2015 - Myron Papadakis

A| Actions L
Enter the pararneters for the W5DL operation "process” and click Go to
invoke, ~
~ Endpoints
http://localhost:8080/ode/processes/HelloWorld ﬂ
- Bﬂ-d]l'
= HelloWorldRequest
— X
input string >
e Elcome to BPEL
y
i Status &
= HelloWorldResponse
W
result (string): Welcome to BPEL
25




Option 2

e Deploy to ODE in Tomcat

e Create afolder in tomcat/webapps/ode/WEB-INF/processes
e Copy the .bpel file, .wsdl file and the ODE deploy.xml

e Restart Tomcat and visit http://localhost:8080/ode

e An extra file will be created with the extension .deployed inside

18/5/2014 CS-592 Spring 2015 - Myron Papadakis
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Clients

e Since the bpel process is itself a web service, clients can be
created in the same way as demonstrated in the previous labs

(stubs,etc) =

* args
public static void main(S5tring[] args) {
HelloWorldServiceStubk stub = nmnll;
try {
stub = new HelloWorldServiceStub ()
} cateh (AxisFault e} {
e.printStackTrace () :
i
HelloWorldBRegquest helloWorldBRequest = new HelloWorldRegquest():
Scanner scanner = new Scanner (System.in):
System. ont.println("Enter input: ")
helloWorldRequest.setInput (scanner.next () ) ;
try {
HelloWorldResponse r = stub.process (helloWorldRequest ):;
)

. & helloworld.HelloWorldServiceStub.HelloWorldResponse
} cal

E Properties | Bl Conso = RE S SR * 3& |
cterminated= Client (2) [Java Application] C\Program Files\JavaijreMbin'javaw.exe (May 6, 2014 12:12:58 PM)

Enter input:

result

18/5/2014 - "¥*9%5-592 Spring 2015 - Myron Papadakis 27



Modifying the Hello BPEL Project

[EI receivelnput ]

i% Assign >

[@ replyQutput ]

=

= it

ME Console} B tcpap Mun'rtor} = |

= Assign

Description [ Validate

Details Fixed Value to Variable From: | Expression W | Toe Variable W

Join Behavior Expression to Yariable

WTH‘ER‘M\ @ input: HelloWorldRequestMessage
Mamespaces

Documentation

18/5/2014

concat{'Hello ",$input.payloadw
\\

| Mew

” Delete

| Mowve Up

| Move Down

[ ]Ignore Missing Source Data

CS-592 Spring 2015 - Myron Papadakis

@ output: HelloWaorldResponseMessage
4] payload : HelloWorldResponse
[€] result: string

Cuery: | tnsiresult

[ ] Keep Source Element Name
287




Modifying the Hello BPEL Project

[J] Clhentjava &5 = HelloWorld.bpel &4 HelloWorld>enncestub,java ZF HelloWorldArtitacts.wsdl

package client:

[ PR % B B

i= HelloBPELProject
4= bpelContent
u.jf deploy.xml
2 HelleWorld.bpel
= HelloWorld.bpelex
A? HelloWorldArtifacts.wsdl
= HelloBPELProjectClient
A JAX-WS Web Services
‘28 Deployment Descriptor: Hello

# import java.rmi.RemoteException:[]

public class Client {

= public static volid main(String[] args) {
HelloWorldServiceS5tubk stub = null;
try {
stub = new HelloWorldServiceStub():
} catch [(AxisFault e) {
e.printStackIrace():

% Java Resources

i src

B client

. . HelloWorldRequest helloWorldBegque=st = new HelloWorldReguest():
[J] Client.java

Scanner sScanner = new Scanner (System.in):
_E'E helloworld System.out.println ("Enter input: ");
m HelloWorldServices helloWorldRequest.secInput (Scanner.next [} ) ;
=, Libraries try
4] Scrint R HelloWorldResponse r = stub.process (helloWorldRegquest ) ;
B a*.r.a Crpt hesources Syvstem.out.println ("result = "+r.getResult{))
= build } catch (REemoteException 2) {
§= WebContent
% build.xml £ Properties | & Console i3 B 1CP/IP Monitor |

<terminated> Client (2] [lava Application] C:\Program Files\JavaljreT\bin\javaw.exe (May 6, 2014 12:27:43 PM)
Enter input:
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